1. TJE Power Bl workshop-harjoitus 16.4.2024

Tama workshop materiaali on tuotettu osana Tiedolla johtamisen keskus BIC:n, Tiedolla
johtamisen edellakavijat -hanketta Satakunnan ammattikorkeakoulu Oy:n ja Knobbi Oy:n
yhteistydna. Workshop-harjoituksessa ei kdytetad aina tavanomaisinta valintaa, vaan harjoituksen
tarkoituksena on luoda ymmartamys Power Bl:sta, jotta yritykset saisivat ideoita ja pystyisivat
jatkossa itse hyodyntamaan Power Bl:n toiminnallisuuksia datan raportoinnissa.

Aloita tallentamalla sdhkopostitse lahetetty, tietoldhteena kaytettava Excel -tiedosto
tietokoneellesi hakemistoon, josta l6ydat sen helposti. Taman jalkeen avaa aiemmin asennettu
Power Bl Desktop. Voit sulkea avautuvan tervetulonakyman.

2. Perusasetukset ja tietojen tuominen Power Bl:hin

Asetukset

Mallin kieleksi valitaan suomi, jotta malli kasittelee oikein pilkkuja ja adkkdsia. Sovelluksen kielena
suositellaan kaytettavaksi englantia. Kieliasetukset astuvat voimaan, kun Power Bl Desktop
kaynnistetddn uudelleen. Kieliasetukset maaritellaan vain kerran.

Tiedosto (File) -> Asetukset ja vaihtoehdot (Options and settings) -> Valinnat (Options)-> YLEINEN
(GLOBAL), Aluekohtaiset asetukset (Regional Settings):

e Sovelluksen kieli (Application language) Englanti (English)
e Mallin kieli (Model language) suomi (Finland)

Options
GLOBAL Application language
Data Load Language used in the Power Bl Desktop user interface, such as the ribbon and dialog boxes.

English (United States) =
Power Query Editor

DirectQuery

Model language
R scripting
Language used when comparing strings in data and for creating internal date fields. This only applies when a report is first created, and can't
Pythan scripting

be changed on existing reports.

Security - =
sty Finnish (Finland) ~
Privacy
| Regional Settings DAX separators
it Specify the culture to use for list and decimal separators in DAX expressions:
Usage Data @ (Recommended) Use standard DAX separators: comma () as list separator and dot (] as decimal separator
Diagnostics Use localized DAX separators: list and decimal separators are defined by Windows locale settings

Preview features
Save and Recover Leamn more

Report settings



Poistetaan kaytdsta suhteiden automaattinen luonti. TAma on tiedostokohtainen asetus ja
maariteltava erikseen uudelle Power Bl -tiedostolle.

Tiedosto (File) -> Asetukset ja vaihtoehdot (Options and settings) -> Valinnat (Options)->
NYKYINEN TIEDOSTO (CURRENT FILE), Tietojen lataaminen (Data Load). Ota suhteiden
automaattinen luominen (Autodetect new relationships after data is loaded) pois paalta.

Options
GLOBAL Type Detection
Data Load Detect column types and headers for unstructured sources

Power Query Editor . i
Relationships

DirectQuery

. mport relationships from data sources on first load
R scripting

o Update or delete relationships when refreshing data (@)

Python scripting

i Autodetect new relationships after data is loaded
Security

i Learn more

Privacy

Regional Settings - - .
g g Time intelligence
Updates .
Auto date/time (D) Learn more
Usage Data

Diagnostics
2 Background Data
Preview features
Allow data previews to download in the background
Save and Recowver

Report settings Parallel loading of tables ©

CURRENT FILE Maximum number of concurrent jobs  Learn more

I Data Load @® Default

- One (disable parallel loading)
Regional Settings : P <

Custom
Privacy
Auto recovery
Published dataset settings Q&A

Query reduction
Learn more

Report settings

Tallenna tiedosto nimella: File -> Save as

Tietojen tuominen Power Bl:hin

e Valitse aloitus (Home) valilehdelta Nouda tiedot (Get data). Valitse Excel Workbook ja
klikkaa Avaa (Connect) painiketta.
e Siirry avautuneessa tiedostonhallinta-ikkunassa hakemistoon, jonne olet tallentanut
tdman harjoituksen Excel-tiedoston.
e Klikkaa hiirella tiedostoa ja valitse Avaa (Open).
o Valitse avautuvasta navigointi-ikkunasta tuotavat taulut:
o Asiakas
o Tuntikirjaus
o Tydntekija
o Yhtidn tiedot



Get Data

Search All
o Iﬂ Excel Workbook .
Text/CSV
File B
XML
Database B
JSON
Microsoft Fabric
(Preview) Folder
Power Platform [ poF
Azure % Parquet
Online Services B SharePoint folder
Other SOL Server database v
Certified Connectors |~ Template Apps Cancel
1 Open X
&« E O " « Tiedolla johtamisen edelldkavijd > workshop w &) Search workshop »
et =-ae
S
v | Hankkeet Mame Status
> Tiedolla johtamisen edellakavija | Tyakirjauskanta @
> T Hill-
> Liitteet
» 0 Matkat
>  Moodle
> New folder
File name: | Tyskifauskanta V| _ Excel Files ("™ xlsx;* xlsm;*xl ~
Open Iv Cancel
O
Navigator
) Yhtion tiedot &
Display Options ~ l_—?,‘ Preview downloaded on torstai 28, maaliskuuta 2024
4 [ Tyskirjauskantaxdsy [4] Ll ook
. T&T Tietoconsulting O null
B [ Asiakas g Oy
nulf null

B I Tuntikijaus
B 0 Tysntekija

B [l vhtien tiedot

4 Suggested Tables [1]
[ E Table1 (Asiakas)

Teimitusjohtaja Teppo Tietomies

Hallituksen puheenjohtaja Taina Tietomies

Transform Data | | Cancel |




3. Tyoskentelya Power Bl Desktopilla

Valitse raportointi -nakymassa (Report view):

1. Visualisoinneista (Visualizations) taulukko (Table).
2. Tiedot (Data) Asiakkaan Nimi.

ELEErTIE) wdd

[ o - =
Visualizations | > |Data | > Asiakkaan Nimi
Build visual | —
= + Search Aurinkorannikon Automaalit ja Korjaamo
e
- "E?-’ @'.. . Oy
— ~ BpAsiakas Jarvisuomen Juhlapalvelu ja Pitopalvelu
E g E Ih:ﬂ E i [0  AsiakaslD Oy
& @ @ E Lq:ﬁ Lﬁ [0 Asiakkaan lasku... | Kultaisen Kuusen Kahvila ja Konditoria Oy | ||
: | Asiakiaan Nimi Kapalamaen Kukka ja Kehra Oy
E Iﬂﬂ] = |_ ® @ 0 Toimiala Lumisalon Laskettelukeskus Oy
BOBARD ;g ruias Vetanpeikon Mokiivaitys Oy
5 R - nteki's ohjolan Pehmoiset Pyyhkeet Oy
L=!? E > @ Tyonteki Revontulen Ratsastuskoulu Oy
Py E° =B [ 1) ©@ > @ Yhtion tiedot Saariston Savusauna ja Spa Oy
Wake o2 Lo —
3. Lisaa edellisessa kohdassa luotuun tauluun uudeksi tiedoksi Tuntikirjaus (h)
[ - — =1
Visualizations » |Data >
Build visual O .
— - earc
= T @
o~ V%ﬂlsiakas
E[HHE']][I]EM SZAsiakasD ®
Asziakkaan lasku...
P M R Bk Asiakkaan Nimi Can’'t determine relationships between
ZMFL OO . the fields See details !
EEQ@W A~ © By Tuntikidaus m
E@R O % Asiakas 1D
PyED@D 'a EQJ [0 2 Henkilén ID
@ i ﬁ.u_? & @ 7 > [ B Psivamasrs
O % Rivi
] Selitys L — J
Lallimrs Tuntikirjaus (w Y B -

Visualisointi rikkoontui, kun visualisointiin lisattiin tietoja kahdesta eri taulusta. Tallaisessa

tapauksessa kannattaa tarkistaa tietomallista, onko kyseisten taulujen valilla olemassa relaatio eli
suhde.

4. Siirry tietomalli -nakymaan (Model view)

5. Yhdista taulut raahaamalla yhteinen avainkentta taulujen valilla.
a. Tyodntekija ja Tuntikirjaus -taulut (HenkilénID)
b. Asiakas ja Tuntikirjaus -taulu (AsiakaslD)



(2] Tysntekija

I Henkilén 1D I

Henkilén Nimi

EI Asiakas LA

[l AsiakaslD | ]

Asiakkaan laskutusosoite

HeTu
Kustannushinta alv 0 Asiakkaan Nimi
Laskutushinta alv 0 Toimiala
Yhsikka Collapse ~
Collapse ™ 1
4
El Tuntikirjaus
Asiakas ID
Henkilén ID
) ¥ LE Paivamaara ¥
2 Rii
Selitys
Tuntikirjaus (h)
Collapse
6. Palaa tarkistamaan tilanne raporttinakymaan.
= - =1

Asiakkaan Nimi

Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Aurinkorannikon Automaalit ja Korjaamo Oy
Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy
Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy
Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy
Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy

Tuntikirjaus (h)

2
25
2.75
3
3.25
3.5
4
45
2.75
3

4
425

Huomataan, etta tuntikirjausta ei voida laskea yhteen vaan jokainen tuntikirjaus nakyy erillisena
rivina. Kun tarkastellaan asiaa tarkemmin taulukkonakymasta (Table view) huomataan, etta
Tuntikirjaus (h) on tekstimuotoinen tieto. Tama johtuu siita, etta Excelissa, josta tiedot tuotiin
Power Bl Desktop -sovellukseen, on desimaalipilkut merkitty pisteina. Jotta aineisto saadaan
toimivaksi, pisteet on muutettava pilkuiksi ja muotoilu tekstistd numeroksi. Taman kaltaiset
muotoilut tehdaan PowerQuery -moduulissa.



Calumns Tuntikirjaus ()
Asiakkaan Nimi o > B Tysntekijs
Tuntikirjaus (h) ~ Remove field

Rename for this visual
Drill through

Move >
Cross-report

Conditional formatting >

Keep all filters On®|

Add drill-through fields he - pon't summarize
First

Last

Count (Distinct)
Count

New quick measure

Show items with no data

New group

@ Mame Tuntikirjaus (h) 55 %rmlt Text v | > Summarization | Don't summ
f};z Clata type EI Data category | Uncategoriz

Structure Formatting Propertiss

w X v
Rivi |~ | Henkilén ID |~ | AsiakasID |~ Paivimaira -

| E 7 1 1 maanantai 1. tammikuuta 2024 4 Asiakkaan
2 2 2 maanantal 1. tammikuuta 2024 3.5 Tiedanker
ﬂg 3 3 3 maanantat 1. tammikuuta 2024 525 Maataloug
m 4 4 4 maanantai 1. tammikuuta 2024 4 Hiihtokesk
o 5 5 5 magnantal 1. tommikuuta 2024 3 Kahvila- ja
& ] §  maanantal 1. tammikuuta 2024 2 Kiinteistaw
7 7 7 maanantat 1. tammikuuta 2024 45 Autamaalz
8 8 8 maanantai 1. tammikuuta 2024 3.75 Saunapaly
g 9 9 maanantal 1. tommikuuta 2024 2.25 Ratsastusk
He 10 10 maanantal 1. tammikuuta 2024 3 Juhlapalve

7. Siirry Power Query -moduuliin Aloitus (Home) -valilehden Munna tieto (Transform data) -

painikkeesta.
File Home Help Table tools Column tools
28 > | B | & =8
o mm O hEe % of
Get Excel Onelake SQL Enter Dataverse Recent Transform Hefresh Mana
data~ workbook data hub ~ Server data sources v data v relations
Clipboard Data Queries Relations

8. Valitse vasemmasta reunasta Tuntikirjaus -kysely ja aktivoi klikkaamalla Tuntikirjaus (h) sarake.
Tee seuraavat muutokset:

a. Klikkaa hiiren kakkosnappaimella sarakeotsikon paalla ja valitse Korvaa arvot (Replace
Values). Merkitse avautuvaan ikkunaan etsittavaksi arvoksi (Value To Find) piste ja
korvaavaksi arvoksi (Replace With) pilkku. Hyvaksy OK-painikkella.

b. Klikkaa hiiren ykkdsnadppaimella sarakeotsikon vasenta reunaa ja valitse desimaali luku
(Decimal Number)



Home  Transform Add Column  View  Tools Help
i s — I g| ; [%m Properties B L % -W AL Data Type: Text ~ H
-t - = L4 =l —Fs [ Advanced Editor X . FA [7] Use First Row as Headers = =
Close&  New Recent Enter Datasource  Manage Refresh Choose Remove  Keep Remove Split  Group |
Apply~  Source~ Sources~ Data settings Parameters = Preview = | | Manage - Columns = Columns = Rows~™ Rows~ Column~ By -2 ReplaceValues
Close Hew Query Data Sources  Parameters Query Manage Columns Reduce Rows  Sort Transform
Querias [4] < Jc || = Table.TransformColumnTypes(#"Promoted Headers",{{"Rivi", Int64.Type}, {"Henkildn ID", Int64.Type}, {"Asiakas ID", Int]
. 23 Rivi ~| 123 Henkilon ID [+] 125 Asiakas ID [~ = Paivamaara Selitys
1 1 1 1 11 L Kap
1 Tyontekija 2 2 z 2 1.1.2024 35 Tiedonkeruu Ja
] Yhtisn tiedot 3 3 3 3 1.1.2024 535 WMaatalouden d
4 4 4 4 112024 4 i ik
5 5 5 5 112024 3 Kahvila-ja kon:
6 6 6 6 112024 2 finteistoual
7 7 7 7 112024 45
[ 8 3 E 1.1.2024 375
o a a a 112024 295 L
'-w FE——
——— Copy - Rep|ace Values
112024 4 | ka ja K|
%  Remove . ;
112024 35 Q Other Col hjolan Replace one value with another in the selected columns.
emove Other Columns P
112024 525 pinti ja| Value To Find
: alue To Fin
112024 4 Duplicate Column yysi L
112024 3 [0 Add Column From Examples... iminna
. — Replace With
11.2024 2 Remove Duplicates joiminn) e
11202445 Remove Errors nnan a :
112024375 -analy]
Change Type 3 b Advanced options
112024 225 tasuul
Transform 3
112024 3 slasken
1 L
212024 325 sz ReplaceValues... 5 Oyn
212024 4 Replace Errors... 5sien o

Cancel

Tuntikirjaus (h)

Decimal Number
Fixed decimal number ber
Whole Number ou:
Percentage jesk
Date/Time -is
Date fro
Il
Time -
Jalv]
Date/Time/Timezone
sk
Duration
Ive
Text ]
True/False de
. ou
Binary
elli
Using Locale... =n
IMetsanoe!

9. Tallenna muutokset ja palaa PowerBl:hin Aloitus (Home) -valilehden Hyvaksy & sulje (Close &

Apply) painikkeesta.

Home Transform Add Column View Tools Help
L = I ﬂ| [ [ Properties e L % - 2! I Data Type: Decimal
N - L3 = R —E Advanced Editor - x b : il [T Use First Row as
New Recent  Enter Data source Manage Refresh __ Choose  Remove Keep Remove Split Group 1
Source ~ Sources* Data settings Parameters~  Preview > | | Manage ~ Columns~ Columns~ Rows~ Rows~™ Column~ By 7 Replace Values
Mew Query Data Sources  Parameters Query Manage Columns Reduce Rows Sort Transform
Queries [4] < fx = Table.TransformColumnTypes(#"pisteet pllkuksi”,{{"Tuntikirjaus (h)", type number}})
5 Asiakas . |13 Rivi [+] 1% Henkilan ID [+] 1% Asiakas ID [~ % paivemaara fal12 Tuntikirjaus {
—
T Tuntikigaus 1 1 1 1 1.1.2024 4
B Tydntekija 2 2 2 2 1.1.2024 3.5
— . N 112024 52




10. Ota tuntikirjaukselle kadytt6on summa (Sum) -ominaisuus raporttinakymassa.

r - — o [Pseaen ]
Asiakkaan Nimi Sum of Tuntikirjaus (h) ::; ﬁ @ @\
Aurinkorannikon Automaalit ja Korjaamo Oy 36,00 w o —" v Bypsiskas
Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy 40,25 E /M E 2 i [l AsiskasiD
Kultaisen Kuusen Kahvila ja Konditoria Oy 45,50 e Oh kA PR B LR E Asiakkaan lasku..
Kapalamaen Kukka ja Kehra Oy 47,50 B = Asiakkaan Nimi
Lumisalon Laskettelukeskus Oy 31,25 lg mﬂ] = L ® @ (] Toimiala

I Metsanpeikon Makkivalitys Oy 41,00 I @ WA= ~ EpTuntikisjous
Pohjolan Pehmoiset Pyyhkeet Oy 40,75 Es E R O]  AsiakasID
Revontulen Ratsastuskoulu Oy 47,75 Py EE =17 T O  Henkilsn ID
Saariston Savusauna ja Spa Oy 37,00 @ = B @ ® 73 > O] & Paivamaara
Suvannon Sailérehu Ky 62,25 = O X Rivi
Total 429,25 (] Selitys

L — J Columns T Tuntikirjaus (k)

S
Sum of Tuntikigiaus ()~ e o

Rename for this visual
Drill through
— Move >
Cross-report (@or
Add a sparkline
Keep all filters on®
Conditional formatting >

~ Sum

Average

Add drill-through fields he

Minimum

Maximum

Count (Distinct)

11. Luo tehdysta taulusta uusi visualisointi:

a. Kopioitaulu klikkaamalla hiiren kakkosnappaimella taulun paalla ja valitsemalla kopioi
(Copy). Vaihtoehtoisesti voit kayttaa komentoa Ctrl+c. Luo uusi taulu Ctrl+v -
komennolla. Siirrd uusi taulu pois vanhan paalta.

b. Muuta uuden taulun visualisointi palkkikaavioksi (Stacked Bar Chart).

c. Nimea valilehti "Tunnit asiakkaittain”

<« Visualizations »
< B visusl

Asizkicaan Nimi Sum of Tuntikirjaus () "Sum of Tuntikirjaus (h) by Asiakkaan Nimi = . 4 &K
Aurinkoranniken Automaalitja Korjaame Oy 3600 B
Janvisuomen Junlapalvelu Ja Pitopaivelu Oy 4025
Kultaisen Kuusen Kahvils ja Konditoria Oy 4550 _ @ b B e
Kapalamaen Kukka ja Kehra Oy 4750 5 EFOO
Lumisalon Laskettelukeskus Oy 3125 T HeCWAmD
Metsénpeikon Makidvalitys Oy 41,00 13 EEEEDr
Pohjolan Pehmoiset Pyyhkeet Oy 4075 % = iy
Revontulen Ratsastuskoulu Oy 775 & YE-EIB P
Saariston Savusauna ja Spa Oy 37,00 (FRAREE Ko7
Suvannon Sailorehu Ky 62.25
Total 42925 . -

Y-anis

L Sum of Tuntikirjaus J
- Asizkkaan Nimms ®

X-anis

Sum of Tuntikigaus (h) x

Legend

ek dsta elds here

S mazpies

Ackddata s here

Tesltips

Ackddota feds here

Drill through

=
(o0 ]
Add il hrough fields here

12. Tehdaan PowerQueryssa loput muutokset:
a. Asiakas -kysely:
i. AsiakasID tekstimuotoon



ii. Suodata Asiakkaan Nimi sarakkeesta tyhjat pois
b. Tuntikirjaus -kysely
i. Poista Rivi-sarake
ii. HenkilonID tekstimuotoon
iii. AsiakaslD tekstimuotoon
c. Tydntekija -kysely
i. HenkilonlD tekstimuotoon
ii. Poista HeTu-sarake
d. Yhtion tiedot
i. Kayta ensimmaista riiva otsikkona (Use First Row as Headers)
ii. Poista tyhjarivi
13. Sulje & hyvaksy muutokset (Close & Apply)

14. Lisaa uusi valilehti alareunan plus-merkista ja nimea valilehti nimella Tyontekijoiden tunnit.

] D Tunnit asiakkaittain TyGntekijdiden tunnit

15. Tee valilehdelle seuraavat asiat:
a. Lisaavisualisoinneista taulu ja ota mukaan seuraavat kentat: Asiakas (Asiakkaan
Nimi), Tuntikirjaus (Henkilon ID ja Tuntikirjaus (h)). Muuta sarakkeiden jarjestysta
taulussa niin, ettd vasemmanpuoleisin sarake on HenkilonlD, sitten Tuntikirjaus (h) ja
oikeanpuoleisin Asiakkaan nimi. Ala tee laskutoimituksia HenkildID:n kohdalla,
Tuntikirjaukset lasketaan yhteen (summa).

— « Visualizations » Data >
Henkilén ID Sum of Tuntikirjaus (h) Asiakkaan Nimi h < Buid vl P Search
, : : s O @
1 5,00 Aurinkorannikon Automaalit ja Korjaamo Oy g o~ v@Agaka:
1 9,00 Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy E LEH E O  AsiskasiD
1 10,00 Kultaisen Kuusen Kahvila ja Konditoria Oy ﬁ @ @ O  Asiakkaan lasku..
1 15,25 Kapalamaen Kukka ja Kehra Oy Asiakkaan Nimi
1 5,25 Lumisalon Laskettelukeskus Oy \E “]‘_[ﬂ = L O Toimisla
| 700 Potln et Phest O reF R
1 10,50 Revontulen Ratsastuskoulu Qy E‘ g Asizkas 1D
1 8,00 Saariston Savusauna ja Spa Oy Iy E ELTE @ Henkilon 1D
1 10,25 Suvannon Sailorehu Ky @ iz f&? @ o2 > U & paivamaara
10 3,50 Aurinkorannikon Automaalit ja Korjaama Oy O seitys
10 10,50 Jarvisuomen Juhlapalvelu ja Pitopalvelu Oy 2 Tuntikirjaus (h)
10 3,25 Kultaisen Kuusen Kahvila ja Konditaria Oy Calmia ~ B Tyntekija
10 4,00 Kapalamaen Kukka ja Kehra Oy Henkilsn 1D v X [0  Henkilgn ID
10 2,75 Lumisalon Laskettelukeskus Oy Sum of Tuntikifjaus [h) “ % O  Henkilsn Nimi
Total 428,25 Asiakkaan Nimi ~ % [0  Kustannushinta...
O Laskutushinta a...
Drill through (] Yisikks
Cross-report > B Yhtin tiedot
Keep all filters On @
Add drill-through fields here




b. Kopioiluotu taulukko ctrl+c -komennolla ja liita ctrl+v -komennolla. Muuta visualisointi
Puukartaksi (Treemap). Poista asiakkaan nimi visualisoinnista.

«  Visualizations » Data >
; m @ @ M Search
. S - - - g L~ [ Asiakas
Sum of Tuntikirjaus (h) by Henkilon 1D v OEZ - E i E i = [ ] AsiakasiD
[ Asizkkaan lasku...
b b W B It e O Asiskkaan Nimi
e 0o O  Toimiala
33-' B A= ~ yTuntikifaus
S EE R [ Asiskas 1D
Py = = [ & TP Henkilgn ID
m i) 5@ @D > [ B paivamaara
O selitys
3 Tuntikirjaus (h)
Categery B Tyontekija
Henkilsn 1D % O  Henkilsn ID
(] Henkildn Nimi
Details O Kustannushinta...
Add data fields here (] Laskutushinta a...
Values O Yksikks
Sum of Tuntikirjaus (h) ~ X R
Tooltips

c. Tee Puukarttaan TOP5 -suodatus Suodatus (Filters) -paneelin kautta. Suodata Henkilon
ID -kenttaa seuraavasti:
i. Suodatuksen tyyppi (Filter type, TOP N)
ii. Naytettdva maara (Show items, Top 5)
iii. Arvo, jonka mukaan suodatus tehdaan (By value, Sum of tuntikirjaus). Kentta
raahataan kyseiseen kohtaan.
iv. Ota suodatus kayttoon klikkaamalla Apply filter.

IV Filters G |Visua|izati0ns » Data »
o Build visual 5
TSum of Tuntikirjaus (h) by Henkilan 1D 7 & - = T @
. ~ Bl Asizkas
Filters an this visual o
Henkilgn 1D E lE-H E I]ﬂ E mﬂ g t:::z lasku...
top 5 by Sum of Tunti... E @ & E IEEH I& O et
. 13| 1an Nimi
Filter type O |§ |J]‘_[ﬂ = |_ @ @ O Toimiala
Top N - g Bg A R VQTUMI”(II’JEUS
Show items E‘? @ @ R O Asiakas ID
| Top ~s | Py ° =B [1 &) @@ Henkilan ID

By value @ i) ﬂf‘? & ® S5 > [ B Paivamaars
| Sum of Tuntikifjaus (h) v X | O Selitys

¥ Tuntikirjaus (h)

Category ~ [ Tysntekijs

Su(rAn”:]Jf Tuntikirjaus (h) Henkilsn 1D ~ X O Henkilsn ID

£3

O Henkilgn Nimi
Details -
Add data fields here L Gstenushinte.

Add data fields hers O Laskutushinta a...

) ) Values U T

Filters an this page > B Yhtien tiedat

Sum of Tuntikirjaus (h) ~ X

Add data fields here
Tooltips




16. Tee molemmille raporttisivuille osittajat (Slicer)

a. Tunnit asiakkattain -raporttisivu

TValitse yksikkd / tyéntekija Y B2 el
~ [] Strateginen Analytiikkayksikks
~ [] Taloudellisen Analytiikan yksikko
I I
~ [] Tietostrategiayksikk&
~ [_] Toiminnanohjaus ja optimointiyksikk&
L - |
TValitse vuosi / kuukausi B2 o]
~ [ 2024
| I
I - |

b. Tyodntekijoiden tunnit -raporttisivu
P Search u

| Automaalit ja autokorjaamo
Hiihtokeskus
Juhlapalvelut ja pitopalvelu
Kahvila ja konditoria

Kiinteistdnvalitys '

Kukkakauppa 9
All A~
- -
B v L| B2 LI
r Kuukausi, Paiva 1
P Al N
[ — 2l

= =R EE R
Py E = 19 @
WELe 2

Field
Yksikka K
Henkilén Nimi X

EEEBE R
Py E =B 1 {9 ©
wWELZe ®2

Field

Paivdmaara WX
Vuosi s
Kuukausi s

Py &
W &=

Field

Toirmiala

g EH B R

€018 P
Re o

EEEEBE-R
PyE =B @
hBEEe 2

Field

Panvdmasra
Kuukausi
Paiva



